如果没有 HTTPS,浏览器会将您的网站标记为不安全,表单数据以明文传输,搜索排名也会受到影响。免费证书只需几分钟即可获得。
为什么在签发证书之前,我的域名必须指向虚拟主机?
只有当证书颁发机构能够通过访问域名所指向的服务器来验证该域名归您所有时,才会签发证书。只要您的 A 记录没有指向您虚拟主机的地址,签发就会失败。
请首先检查这一点:
- 在我的服务中打开您的域名详情页,进入 DNS 解析区选项卡。
- 检查域名的
A记录(名称为@)是否指向虚拟主机详情页上 IP 地址中显示的地址。 - 如果您刚刚修改过该记录,请耐心等待:传播时间取决于旧记录的 TTL。
如何为我的网站获取免费的 SSL 证书?
从客户中心打开 Plesk,进入 Websites & Domains,然后打开 SSL/TLS Certificates,点击 Let’s Encrypt 下方的 Install,最后点击 Get it free。
- 在客户中心点击 自动登录打开 Plesk。
- 打开 Websites & Domains,然后打开 SSL/TLS Certificates。
- 点击 Let’s Encrypt 下方的 Install。
- 填写一个联系邮箱地址。
- 勾选包含 www 子域名:否则,
www.yourdomain.tld将显示证书错误。 - 如果您使用虚拟主机的邮件服务,还请勾选 webmail 域名。
- 点击 Get it free。
证书有效期为三个月,并且会自动续期。只要您的域名继续指向该服务器,您就无需进行任何操作。
如何强制网站的所有访客使用 HTTPS?
在 Plesk 的 Websites & Domains > Hosting Settings 中勾选 Permanent SEO-safe 301 redirect from HTTP to HTTPS。
仅安装证书还不够:还必须将访问 http:// 地址的访客重定向到 https:// 地址。
在 Plesk 中,打开 Websites & Domains > Hosting Settings,然后勾选 Permanent SEO-safe 301 redirect from HTTP to HTTPS。这是规范的做法,搜索引擎也能正确识别。
如果您的应用自行管理其网址(WordPress、PrestaShop、Joomla),请记得也在其设置中将基础 URL 改为 https:// 开头,否则它会继续生成明文链接。
为什么有了证书,网站的锁形图标仍然显示为不安全?
页面已经通过 HTTPS 提供,但浏览器仍显示警告?这几乎总是因为混合内容:页面中仍有图片、样式表或脚本通过 http:// 加载。
- 按
F12打开浏览器控制台,进入 控制台 选项卡。 - 出问题的资源会连同其完整地址一起列在那里。
- 在您的主题、文章或数据库中修正它们。在 CMS 上,一个搜索替换插件即可一次性完成这项工作。
最常见的证书错误分别代表什么?
大多数错误源于证书中缺少某个名称(最常见的是 www),或者域名已不再指向该服务器。
- 「证书与网站名称不匹配」:您通过证书中未包含的名称访问网站,通常是
www。请重新签发包含该子域名的证书。 - 「证书已过期」:自动续期失败,几乎总是因为域名已不再指向该服务器。请修正 DNS 区域,然后重新签发。
- 签发立即失败:请检查
A记录,并确认没有任何重定向干扰验证请求。 - 尽管设置了重定向,网站仍以 HTTP 显示:请清除浏览器缓存以及 CMS 的缓存。
我的证书也涵盖子域名吗?
证书涵盖您在签发时勾选的名称。如果您之后添加了子域名(例如 blog.yourdomain.tld),请重新签发证书以将其包含在内,或在同一页面上为其申请一张单独的证书。